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ANT-1774 - Quick start guide
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When using the ANT-1774 please ensure all anti-static precautions are taken.

Do not connect the Ethernet connection from the ANT-1774 to a POE port on an Ethernet switch
as this may damage the ANT-1774.

Please note the power supply is 5V centre positive, there is no operating range like 4 ~ 9 volts.

The ANT-1774 does not have a web interface and so requires a Windows operating system to run
as application to connect to and configure the ANT-1774. It has only been tested with windows 10
(home and professional) on a 64-bit machine.

Some antivirus software see’s the Application and the ANT-1774 as a virus and does not allow
them to function as expected, so exceptions may need to be added to the installed antivirus
software.

For further help and advice please contact Antrica on:
Email: support@antrica.com
Phone: +44 1628 626098 ext 3

Document info

Version | date author | Comments
1.0 30-Oct-20 | David M | draft release: ANT-1774 code 1.3.21 and PC Application 1.0.4.31
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1. Versions

Table 1 : code versions

Product version | comments

ANT-1774 firmware | 1.3.2 upgrade by Micro SD card only

PC application 1.0.4.31 | To configure the ANT-1774

Neptune player 3.1.4 Low latency software decoder

VLC 3.0.11 Free to download software decoder / media player

The ANT-1774 code is located
https://www.dropbox.com/s/ph6gqbbfb6563s8/Burn%20Files%20ver%201.3.21.zip?dl=0

The “PC application” is located
https://www.dropbox.com/s/1cidn96jh09465i/PC%20Application%20ver%201.0.4.31.zip?dI=0

Neptune Player is located
https://www.dropbox.com/s/k3mrn9upyfgly2i/neptune install 3.1.8.zip?dI=0 and will install as

2. Setup

This guides setup is for a HDMI and analogue input option cards (example) .

In Figure 1 and Figure 2 shows the setup and connections for the ANT-1774. Please note the
power supply is 5V centre positive.

Do not connect the Ethernet connection from the ANT-1774 to a POE port on an
Ethernet switch as this will damage the board.

Figure 1 : SD card side of ANT-1774
o'
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Figure 2 : Option card side of ANT-1774
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The parts indicated in Figure 1 and Figure 2 are briefly Described in Table 2.
Table 2 : Part descriptions

Ident | Description

5V power supply, centre positive. This is 5V only

Debug board - not supplied

HDMI to Micro HDMI adaptor — not supplied, enables a standard HDMI cable to be used
Board Power connecter

Board Debug connector

Serial / setup connector

Serial / setup board

Orange LED - ANT-1774 is booted

Board Ethernet connector

Orange and Green LED’s — Ethernet network activity indicators

Micro SD card holder - for firmware upgrades

Micro SD card

Co-ax cable for analogue camera input - available if analogue option board is used
Ethernet connector — connected to standard Ethernet cable

Micro HDMI connector on HDMI option board

HDMI option board — Channel 12" location

Analogue option board - Channel "11" location

Analogue input connector on analogue option board

PAO|voIZIZIT|IAR~ITTOMMON0|m|>

WARNING: ANT-1774 USB ports are powered and if connected to a PC or
other powered USB port this will irrepairably damage the ANT-1774
Future Firmware will support memory connection to these USB ports
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3. Firmware upgrade

The example below is using the “"Burn Files ver 1.3.21_Nano_UDP” files which will enable the PC
application to connect via Ethernet to configure the ANT-1774.

If the “Burn Files ver 1.3.21_Nano_RS232" are used then the ANT-1774 will be expecting a
connection via the RS-232 module, see G in Table 2. This may be acceptable on the bench but
maybe not so convenient when the ANT-1774 is located in a finished product.

1.
2.

A FAT32 formatted micro SD card is required.

Copy the “Burn Files ver 1.3.21.zip"” file onto a Micro SD card, see section “1 Versions” for
location.

Extract to ROOT of SD card

You should have 2 folders in the root directory of the SD card, these are “Burn Files ver
1.3.21_Nano_RS232"” and “Burn Files ver 1.3.21_Nano_UDP”. If not move the folders
around until you do.

Delete “"Burn Files ver 1.3.21.zip” file

Copy, not move, the contents of “Burn Files ver 1.3.21_Nano_UDP” into the root directory.
The original files maybe required later.

Place the micro SD card in the Micro SD card holder, ID K. from Table 2

Power cycle the ANT-1774, or power on if already off, and wait 4 ~ 5 minutes until LED H
(from Table 2) is on. This indicates the firmware was had been updated and the ANT-1774
is booted and ready to use.

If you look at the files in the root directory on the micro SD card 2 of them have been
renamed, as shown in Table 3. This will prevent the micro SD card from upgrading the
ANT-1774 again at the next power cycle. To upgrade again either manually rename the
files or delete the files (not the folders) in the root directory and then copy the files from
the “Burn Files ver 1.3.21_Nano_UDP” folder.

Table 3 : renamed files after upgrade

Original filename | after upgrade
config config_change
u-boot.bin u-boot_change.bin

Accessing the ANT-1774

Download the “PC Application ver 1.0.4.31.zip", see section “1 Versions” for location.
Extract to a convenient location on PC

Within the folder are 4 files:
brdf.ini
conf.ini
Mercury.exe
udpf.ini

Run the Mercury.exe and override any Windows security issues.

5. The Application will start and look like that shown in Figure 3.

From the top menu select “Interface” -> “UDP” and a popup window will appear, as shown
in Figure 4. The IP address of the PC need top set into "My IP” field, then click "Save”. The
other parameter details are listed in Table 4.

To establish contact with the ANT-1774 check the UDP box, and click "Connect”, as shown
in Figure 3.

As shown in Figure 5 the words “"Connected” and “Ready” are shown.

Click “Read Config.” as shown in Figure 6, and current configuration will be shown.
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Table 4 : Ethernet connection setup

Parameter Function Comments

My IP IP address of PC Must be on a 192.168.0.xxx subnet and not on
running Application 192.168.0.245

Mercury IP IP address of ANT-1774 | The default IP address of the ANT-1774 is

192.168.0.245

Source port Port for packets from This is configurable
PC

Destination Port for packets from Is should not be changed, as it may not be possible to

port ANT-1774 connect the ANT-1774 if it is changed

Figure 3 : PC application

" Metrcury Nano

'llc erface Commect  Jest Comfiguration RBIP11 RIP12 UOPRS
: 1. Check UDP
Maris
, 2. Click “Connect
|_|rszx2 ¢ oSt | |Auto RTP
[ Juoe |_J1AD [ Auto UDPRS
RTSP Stream 11 (Analog) RTSP Stream 12 (HD SOI)
Sensor 1 Input Sensor 2 Input
Stroam Resciution Stroam Resclution
Updiate Update
Bt Rate (Kops) Bt Rate (kbyss) ) . . .
Update Usdate Figure 4 : Ethernet configuration window
GoP GOP
Update Ugdate “UDP Confi... — J p 4
Frame Rate (fps) Frame Rate (fps)
Srete s eisers UDP Configuration
Encoder Format Encoder Format
I My IP
(JAuio [ IRecord Oladio [ IRecord 0.0.0.0
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Not Connected |
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Figure 5 : Connection established

Save Network Configuration  Static 1P

Connected
MTU GWIP
[ ] Enable FEC [emorFEC  FECL=
READY
UDPRS Destination 1P
Subnet Mask

Change Interface to RS2323 Change Interface to UDP
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Figure 6 : current configuration shown

1= Mescury Nano - o x
Ble iterface Comnect Jest Comfiguration BIP11 RIR12 LUOPRS

=~ 1. Read Config.

5. To find versions

To get the ANT-1774 version, from the PC application top menu “File” -> “Get Firmware Version”,
see Figure 7 for example of popup window.

Figure 7 : ANT-1774 code version

Mercury X

A7 1.3.21 NANO:22_10_2020

To get the Application version, from the PC application top menu “File” -> “About”, see Figure 8
for example of popup window.

Figure 8 : PC application version

Mercury X

Application Version: 1.0.4.31
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6. Setting up ANT-1774

1. To set up the correct option boards, from the top menu “Configuration” -> “Board” and a
pop-up windows appears, as shown in Figure 9.

2. Select the options to match the correctly fitted board, then click "Save”. In this example
“Chl 11" is analogue and “Chl 12" is HDMI.

Figure 9 : Board setup option

Board Configuration

Board
[ IMercry  [v|Mercury Nano

Assembly Option
chi11 chl 12
JHD SOI (®)HD SDI
o) Analog L_JAnalog

JHOMI () HOMI
None: ) Nene

Assembly Option Auto Detect

Save

Close

3. The Application now looks like that shown in Figure 10.

4. Now configure the channels:

Set the input formats from the “Sensor 1 Input” or “Sensor 2 Input” drop down menus. NOTE
the analogue input is automatically de-interlaced and converted in to progressive format. The
HD-SDI and HDMI inputs do not support interlaced. Only the listed formats from the drop-
down options are supported.

Between all actions ensure the "Ready” (see the lower part of Figure 10) is present, if not wait
until it is present.

Set the video parameters:
Stream Resolution
Bitrate
GOP
Frame Rate
Encoding Format

The “Update” boxes are for live update of a video stream.
Selected “Auto Start” to auto start the RTSP streamer at power up.

Once the settings are correct, click "Save Config.”.
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Figure 10 : Options board set

"= Mescury Nano - o x
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—————— 2. Save Config.
— 1. Auto Start

_— Ready indication

7. To view RTSP video

To view the view via RTSP the “start Stream” needs to clicked and the Streaming indicator will
show green. The words “Streaming” also appears at the bottom of the PC Application, see Figure

11 for example.
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Figure 11 : RTSP streaming

1= Mescury Nano - o x

Ble Interface Comnect Jest Comfiguration BIP11 RIR12 UOPRS Start Stream

\Streaming on indication - Green light

—— Streaming indication

7.1. Using VLC

To View the video in VLC, RTSP / TCP needs enabling.

Referring to Figure 12

1. From VLC top menu -> Tools -> Preferences
Bottom left “show settings” -> All
Input / Codecs -> Demuxers -> RTP/RTSP
Check “Use RTP over RTSP (TCP)”
Click “Save”

vk wnN
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Figure 12 : VLC RTSP / TCP setting

s Advanced Preferences
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Image ~ . .
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Matroska
MIPEG Client port 1 =
MOD | Force multicast RTP via RTSP
MP4 Tunnel RTSP and RTP over HTTP
WPEG-TS
MPEG HTTP tunned port 80 %
Playsst
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RIP/RTSP ” p——
Subtitie RTSP frame buffer size 250000 v
LDTIDeS

vC-1

To view video:
1. VLC top menu -> Media -> Open network Stream
2. In the “Please entre a network URL:” box add:

For channel 11 add - rtsp://192.168.0.245:554/11
For channel 12 add - rtsp://192.168.0.245:554/12

7.2, Neptune Player

Neptune Player is our low latency software decoder giving around 100ms of latency.

Neptune Player currently has a memory leak and if multiple instances are opened, the PC memory
may “run out” and cause the PC to become unresponsive or crash. If the PC is a low specification
machine it may become unresponsive or crash with only 1 instance of Neptune Player active. This
is being resolved (contact support@antrica.com for latest version).

Neptune player can downloaded and installed from
https://www.dropbox.com/s/k3mrn9upyfgly2j/neptune install 3.1.8.zip?dI=0 and will install
“Neptune Player 3.1.4” and “Neptune Guard 2.4.7".

Extract the file "neptune_install_3.1.8.exe” and run and it will install "Neptune Guard” and
“Neptune Player”. “Neptune Guard” is not applicable for the ANT-1774, but is required for our
other ANT-177x UAV products.

Neptune Guard will require an activation code, see the guide located -
https://www.dropbox.com/s/4aw3g489hjmooov/ANT-177x NeptunePlayerActivation.pdf?di=0

To view video:
1. Neptune Guard top menu -> Network Stream
2. Setup as follows in Table 5, also see Figure 13

3. Click play
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Table 5 : Neptune Player setup

Parameter | Value Comments

Stream RTSP

mode

URL(IP) 192.168.0.245 | IP address of ANT-1774 - is the ANT-1774’'s default value
SDP 12 This is for channel 12, use “11” for channel 11

rstp port 554 Must always be this value

ubp / TCP TCP Must always be this value

Figure 13 : Neptune Player Network Setup

& Network streaming

Stream mode:
Transport
RTP

Split
® RTSP

Network:

URL(IP)
SDP 12
rtsp Port 554

uDP
® TCP

delay (frame count):

Record

Encryption

192.168.0.245

0

Play

| Cancel
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